Jump to content
Sign in to follow this  
DJLambo

Update for Mac Users.

Recommended Posts

I've logged in and it's extremely laggy for me. Is there any plans to make changes so Mac users can play?

 

Thank you in advance!

P.s. This is not a time for the comments like "Apple is shit, get a normal computer". I use a Mac for my line of work, so it's all I have. 

Share this post


Link to post

i haven't tried the update yet, but I have a mac that can also run windows through Bootcamp, if by chance the client won't work properly I'll have to restart into windows and play the game. But honestly I'd feel more comfy playing it on macOS as that's my preferred interface, hopefully devs will fix any lags or errors that will prevent us from having a smooth gameplay of Unova. Let's give them some time.

 

Share this post


Link to post

I also use macbook, currently running OSX version 10.12.5 Sierra and I didn't have to do any changes to play the new update.

Share this post


Link to post
40 minutes ago, DJLambo said:

P.s. This is not a time for the comments like "Apple is shit, get a normal computer". I use a Mac for my line of work, so it's all I have. 

Wow m8 you have so many options here.  

 

First of all you lwan to gam right?  Well if you want access to awesome programs emulators etc windows is the way to go.  Theres a thing called bootcamp just use that and partitioning however much space youre willing to give to it.  

 

Ever since like 2011 macs use intel chips just like windows, there is literally no difference between windows and mac pcs besides software.

 

Posted from my macbook 2008 running windows xp be installed WITHOUT using bootcamp installer lmao

Share this post


Link to post
24 minutes ago, Perreh said:

I also use macbook, currently running OSX version 10.12.5 Sierra and I didn't have to do any changes to play the new update.

I've Sierra 10.12.6... i7, 16GB RAM and Intel Iris Pro 1536 MB... Still laggy as fuck. I guess it's a possibility my internet is too slow to run the update. 

Share this post


Link to post

Currently using a Mac with way lower specs than yours and there are no lag issues on my end. Its quite possible to be a connection issue.

Share this post


Link to post

Go to settings -> Interface -> Show FPS Counter.

 

How much fps you're getting? Also try lowering Anti Aliasing to none if you enabled it and disable overworld in battle.

Overall the 3D should not be much more taxing than our old 2d version tbh. So you should be running fine I think.

Share this post


Link to post
On 15/11/2017 at 8:01 PM, Shu said:

Go to settings -> Interface -> Show FPS Counter.

 

How much fps you're getting? Also try lowering Anti Aliasing to none if you enabled it and disable overworld in battle.

Overall the 3D should not be much more taxing than our old 2d version tbh. So you should be running fine I think.

2 fps outside of battle, 58 in a battle. I have no idea why this is happening! It should be smooth, my computer can run other games at top quality and it's fine. The thing is, it doesn't even sound like the computer is making an effort. For other games with high end graphics, the computer kicks into gear and starts making noise (starts to sound like it's working harder). But for Pokemmo, it doesn't make a sound, it's really frustrating!

 

On 15/11/2017 at 5:44 PM, axx said:

Currently using a Mac with way lower specs than yours and there are no lag issues on my end. Its quite possible to be a connection issue.

Can't be a connection issue, it's 58 fps in battle and 2 fps outside battle. Doesn't make sense!

Share this post


Link to post

I tried it yesterday, and i got like 45-50~fps in battle, and 17-22~ outside of battle.
Game runs at constant 60fps on windows thought Bootcamp though..

Share this post


Link to post

That has to be some mac os related bug then... @Lazaro23 thanks for the feedback. So to make sure, you have more fps when playing through bootcamp than you do when playing osx?

 

Overall there is an upcoming client patch that greatly optimizes rendering and should improve fps drastically for everyone - in some cases it might be over 100% performance gain. So it should be quite noticeable for everyone running on low numbers.

 

I'll bump again this topic again once the client is pushed to ask for feedback @DJLambo

Share this post


Link to post

 

27 minutes ago, DJLambo said:

2 fps outside of battle, 58 in a battle. I have no idea why this is happening! It should be smooth, my computer can run other games at top quality and it's fine. The thing is, it doesn't even sound like the computer is making an effort. For other games with high end graphics, the computer kicks into gear and starts making noise (starts to sound like it's working harder). But for Pokemmo, it doesn't make a sound, it's really frustrating!

 

Can't be a connection issue, it's 58 fps in battle and 2 fps outside battle. Doesn't make sense!

 

Can you check what % of cpu its using when you run pokemmo ?

Share this post


Link to post
1 minute ago, Shu said:

That has to be some mac os related bug then... @Lazaro23 thanks for the feedback. So to make sure, you have more fps when playing through bootcamp than you do when playing osx?

 

Overall there is an upcoming client patch that greatly optimizes rendering and should improve fps drastically for everyone - in some cases it might be over 100% performance gain. So it should be quite noticeable for everyone running on low numbers.

 

I'll bump again this topic again once the client is pushed to ask for feedback @DJLambo

Yeah @Shu , if you can just bump this, I'll update you on the situation. As @Lazaro 23 just stated, through windows on bootcamp it's working fine, so I think I'm going to download the .iso and run it through that for the meantime. Thank you all for your help. Much appreciated!!

 

Share this post


Link to post
8 minutes ago, Shu said:

 

 

Can you check what % of cpu its using when you run pokemmo ?

Wow - 96% CPU... Somethings not right there! I produce music and do graphic design on this laptop with no issues! 

Edit - When I went outside, it shout up to 170% (Not sure how you can have 170% CPU usage but, apparently that's what it says! )

Edited by DJLambo

Share this post


Link to post

Just wanted to bump this thread because the issue is pretty bad for us mac users.

The client update did improve the fps a bit for me, but sadly it appears that I still lag quite a bit.

On the other hand, when I run PokeMMO on bootcamp, it plays flawlessly.

Hopefully a fix will patch it's way in soon!! ^^

Share this post


Link to post

We're pretty sure OSX's OpenGL library is rendering 3d models in software mode for some reason. It's on our list of things to look into more, but I don't have too much faith it's something we will be able to resolve.

Share this post


Link to post
On 15/11/2017 at 5:06 PM, DJLambo said:

I've Sierra 10.12.6... i7, 16GB RAM and Intel Iris Pro 1536 MB... Still laggy as fuck. I guess it's a possibility my internet is too slow to run the update. 

Do you have a FPS problem, or a ping problem? write /ping ingame, and use some software to check your fps like fraps or something.

Share this post


Link to post
On 11/27/2017 at 8:34 AM, Desu said:

We're pretty sure OSX's OpenGL library is rendering 3d models in software mode for some reason. It's on our list of things to look into more, but I don't have too much faith it's something we will be able to resolve.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.