Jump to content
Sign in to follow this  
Kyokatsu

System requirements for gen 5

Recommended Posts

Hello, I quit the game sometime ago for various reasons, but wanted to play again when I heard gen 5 was planned, and got sad cause my pc can barely run DS games with an emulator. However, since I might get a new PC soon, I'm wondering if I'll be able to run it.. any clues on what specs would be good enough to run the game smoothly?

Share this post


Link to post

I'm not sure of the actual requirements or of any tests done on low end machines by devs, but I can tell you that I have multiple friends with really old computers and they had no problem playing the PTS client both times. I don't have any older machines to test myself, but on 2 of my laptops and my desktop the new client (for gen 5) seemed to run WAY better than the current one. It's much faster, more responsive and felt generally smoother.

 

@XelaKebert has a post here with the original system requirements and I feel like the gen 5 client wouldn't be very much more than that, if anything at all. 

 

@Desu could probably answer this definitively.

Share this post


Link to post
13 hours ago, iKole said:

I'm not sure of the actual requirements or of any tests done on low end machines by devs, but I can tell you that I have multiple friends with really old computers and they had no problem playing the PTS client both times. I don't have any older machines to test myself, but on 2 of my laptops and my desktop the new client (for gen 5) seemed to run WAY better than the current one. It's much faster, more responsive and felt generally smoother.

 

@XelaKebert has a post here with the original system requirements and I feel like the gen 5 client wouldn't be very much more than that, if anything at all. 

 

@Desu could probably answer this definitively.

do you have an idea of how old their computers are? Or maybe can you ask them for their specs? Please!

Share this post


Link to post

 

17 hours ago, Kyokatsu said:

Hello, I quit the game sometime ago for various reasons, but wanted to play again when I heard gen 5 was planned, and got sad cause my pc can barely run DS games with an emulator. However, since I might get a new PC soon, I'm wondering if I'll be able to run it.. any clues on what specs would be good enough to run the game smoothly?

The truth is not much needed, I have a computer and a siervio, I try it with computers better and it was the same, so there are no problems
 

 

Share this post


Link to post
1 hour ago, GodofKawaii said:

my computer is a 10 year old hand me down and it ran the pts rather smoothly

 

5 minutes ago, superpichu999 said:

I've had issues running ds games via emulators as well. The PTS client runs so much better, i really dont know how they did it but they did it.

damn, thats too good. Thanks guys

Share this post


Link to post

iirc it requires a open gl 2.0 supported gpu/igpu with around half a gig of dedicated memory which should work on most newer igpus and just about any dedicated gpu made in the last 7 or so years. it'll play on a 710gt, any gfx 600 series, or a old hd 6000 series. you'll run into problem with say a 10 year old igpu off of a Pentium or say a gt 8800 or raspberry pi. that being said if you cherry two of the newer better pi's you can run it in linux no problem.

Share this post


Link to post
4 hours ago, fredrichnietze said:

iirc it requires a open gl 2.0 supported gpu/igpu with around half a gig of dedicated memory which should work on most newer igpus and just about any dedicated gpu made in the last 7 or so years. it'll play on a 710gt, any gfx 600 series, or a old hd 6000 series. you'll run into problem with say a 10 year old igpu off of a Pentium or say a gt 8800 or raspberry pi. that being said if you cherry two of the newer better pi's you can run it in linux no problem.

Fred, it says in the rules that you have to provide an English translation.

 

Dun worry though, I gotchu. Translation:

 

4 hours ago, fredrichnietze said:

If I remember correctly, the new PokeMMO will only require something slightly better than a potato to run. It will run on any Nvidia graphics card that is numbered "gtx 600" or greater; but integrated graphics (the kind that are already in a CPU) that are labeled "hd 6000" or newer will also work fine. You'll only run into problems if you use a potato or a toaster to run the game. If you combine two toasters together, though, that would probably be enough to run the game in Linux (the open source, free operating system).

Edited by Gilan

Share this post


Link to post
1 hour ago, Gilan said:

Fred, it says in the rules that you have to provide an English translation.

 

Dun worry though, I gotchu. Translation:

 

amd made the hd 6000 series.

intel stole the name.

\

oh right and the open gl 2.0 part is important so people can google "is my gpu open gl 2.0 compliant?"

Edited by fredrichnietze

Share this post


Link to post

About all I can say for sure is that the new client will require OpenGL 2.0+ and about 512Mb of RAM. As others have stated, performance and compatibility will start to get spotty with older systems, but some may still be able to handle it. I believe Kyu said that most GPUs >10years will have some issues or be incompatible once Unova is released.

 

You can find the current specs here and you can expect them to be updated once Unova is released.

Share this post


Link to post

My PC has NVIDIA GeForce 6150 and AMD Athlon II X2 235e Dual Core Processor, and it is able to run PokeMMO from the PTS. Of course I had this computer since about 09.

Share this post


Link to post
1 hour ago, Kite said:

My PC has NVIDIA GeForce 6150 and AMD Athlon II X2 235e Dual Core Processor, and it is able to run PokeMMO from the PTS. Of course I had this computer since about 09.

supports open gl 3.3 \o/

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.