Jump to content

[MOD] "Fixed" PokeMMO Music.


eziam

Recommended Posts

"Fixed" PokeMMO music.

 

This mod fixes the side effect from converting the songs to midi. (A future update to Pokemmo will fix the NON-MIDI music, however this mod will fix the music for those who are using the midi engine in PokeMMO)
 
What's that mean? Well, the songs actually use the drum channel in midi correctly! No more off key piano in the background of every song. It is now drums like it should be!
 
I made this mod only because that off key piano was a bother to me, and I knew it was supposed to be drums.

 

I will fix Hoenn region music when we're able to get the IDs for Hoenn's music.
 

 

Download here (V1.1)

Spoiler

Download here (V1.0)

(Yes, the music does loop)

 

Change log

Spoiler

 

V1.1 - Fixed Team Rocket Hideout loop points.

V1.0 - Initial release (Fixed drum channels of music in the Kanto region)

 

 
If there is an issue in game, let me know.

 

(Credit goes to JTE for his "Firered music" mod, I only fixed the drum channel and looping)

Link to post

tfw it takes the community to fix the dev errors

Nice job on the mod, it works really well

I know the dev's did not do it intentionally, though I'm unsure why after more than a year this wasn't fixed. (though its not a big issue compared to other things now)

 

I think it was that they convert the songs to midi automatically, but the conversion doesn't know how to tell what is the drum channel. (I don't know where i heard it but I think that's how it works)

Edited by eziam
Link to post

I know the dev's did not do it intentionally, though I'm unsure why after more than a year this wasn't fixed. (though its not a big issue compared to other things now)
 
I think it was that they convert the songs to midi automatically, but the conversion doesn't know how to tell what is the drum channel. (I don't know where i heard it but I think that's how it works)


I've never heard the issue so it might be environment related. I've heard it mentioned before, but had not gotten time to look into it.

As far as what you did, did you just reorder the channels?
Link to post

I've never heard the issue so it might be environment related. I've heard it mentioned before, but had not gotten time to look into it.

As far as what you did, did you just reorder the channels?

Actually you're correct! (example, the off key piano was on channel 7. Moving it to channel 10 fixes it)

 

In midi, drum channels have to be in channel 10, which before they all weren't. Though there were some songs that had channel 10 but was not actually the drums. So what i did was reorder the songs to make drums, hi hats and all that jazz to work.

 

But i know it wasn't intentional, but i swear i heard it mentioned that midi conversion was automatically done in pokemmo.

Link to post

Actually you're correct! (example, the off key piano was on channel 7. Moving it to channel 10 fixes it)
 
In midi, drum channels have to be in channel 10, which before they all weren't. Though there were some songs that had channel 10 but was not actually the drums. So what i did was reorder the songs to make drums, hi hats and all that jazz to work.
 
But i know it wasn't intentional, but i swear i heard it mentioned that midi conversion was automatically done in pokemmo.


There's issues with drum channels on certain midi environments, and a flag to reorder to fix it.
 

Rearrange channels in output MIDIs so channel 10 is avoided. Needed by sound cards where it's impossible to disable "drums" on channel 10 even with GS or XG commands


Will disable that flag for next update, and see if anyone complains.

Edit: Can you set a custom config option to verify this is the issue?
Make a new file named sound.properties in your /config/ folder with
client.sound_engine.midi.rc=false
Link to post

There's issues with drum channels on certain midi environments, and a flag to reorder to fix it.
 

Will disable that flag for next update, and see if anyone complains.

Edit: Can you set a custom config option to verify this is the issue?
Make a new file named sound.properties in your /config/ folder with

client.sound_engine.midi.rc=false

What's the purpose of this? When i put it in, with this mod disabled of course, it sounds the same as if this mod was disabled, off key piano which is supposed to be the drums. Although in slateport, there were random clicks and jingles from the midi drums. (which if i look in the midi its actually supposed to be applauses, which are generally used in midis to simulate a wind/breeze/gust sound.

 

Is the command supposed to make drums work? because i dont think its that simple without a human to do it. The drum channel in the midis are sometimes on channel 7, or 6, basically they aren't in the same channel from song to song. A human would have to re arrange it manually as far as I am concerned. And midi drums have to be on channel 10 to work, any other channel acts like an instrument other than percussion.

Edited by eziam
Link to post

verdaturf city is buggy. the beginning of it's theme is only drums with this mod

Verdanturf is not in Kanto, so this mod does not mod that. And Verdanturf doesn't have drums in it anyway. It's an issue on your end.

 

 

i dont understand why you need it? i cant tell the diference.

Midi in pokemmo, drum channel is on incorrect channel, and thus no percussion and causes the off key piano in the background in most midis. the most easiest to hear is in cinnebar island. If you instal this mod, it puts the drum.. or that off key piano, into the correct channel (channel 10) so it actually plays the percussion instead of the piano.

Edited by eziam
Link to post

 Can you set a custom config option to verify this is the issue?
Make a new file named sound.properties in your /config/ folder with

client.sound_engine.midi.rc=false

 

I didn't try the line above, because someone already said they had, but you can change this in the main.properties file with a text editor:

 

client.sound_engine.output.midi=true
to
client.sound_engine.output.midi=false

 

I'm not sure if this is what everyone is trying to accomplish, but the music sounds much better just disabling the midi output in my opinion. I like it.

Edited by potalot
Link to post

I didn't try the line above, because someone already said they had, but you can change this in the main.properties file with a text editor:

client.sound_engine.output.midi=true
to
client.sound_engine.output.midi=false

I'm not sure if this is what everyone is trying to accomplish, but the music sounds much better just disabling the midi output in my opinion. I like it.

You can turn off midi engine in the game options.

 

And no, this is not the goal. The goal is to FIX the music in the midi engine, which i have done. The non-midi music is fixed for the next update, but it's not as easy to automate the fixes for midi. I talked to Desu about it though, about a possible fix.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.