Jump to content

[TOOL] Gilan's Encounter Counter (Beta Available) v1.0.2 update


Recommended Posts

Since the tool helps with shunting, what if you were to add the ability to see the EV gains for each pokemon?

As a community we can help add to the list.

for ex. Pidgey +1 Speed

so maybe like

 

Quote

/* PIDGEY is 016, Nidoran M is 032 in pokedex */

016|speed|1

032|attack|1

 

or something in a csv?

 

Edited by EarthBull
Link to comment
On 2/16/2022 at 5:03 AM, DiomanBrando said:

Hey Gilan, i reinstalled the encounter counter again, i fixed the error in my previous post. But i still have the problem that the counter just doesnt count, it only counts the hordes iam encountering. Would appreciate if you could help me out.

if it's counting hordes but not other encounters. Then your ROM's translation doesn't match the translation for my GEC (assuming you have the correct language selected in the GEC settings). It could also potentially have something to do with your battle window's size (i.e. it's cutting out the "A wild {pokemon} appeared!" text in some fashion)

 

In v2.0 that I'm working on, the translation strings for the GEC will be in a separate file so that users can edit them as necessary. It seems 2 ROMs of the same language can have different translations apparently.

50 minutes ago, EarthBull said:

Since the tool helps with shunting, what if you were to add the ability to see the EV gains for each pokemon?

As a community we can help add to the list.

for ex. Pidgey +1 Speed

so maybe like

 

or something in a csv?

 

I'm not sure I see the point of this. That's what the pokedex is for, and you can keep track of EV gains through your pokemon's summary.

Link to comment

I tried this a while back and couldn't get it to work. Tried it again today and its working a treat, I love it

 

Now I can accurately check how many blue and white Pachirisu's I find and cry over before I find another pink one lol

 

Only downside is, I now have to use the arrow keys to escape from battle instead of using my mouse, but its no killer.

Edited by Elizn
Link to comment

Bug report

 

Bug Recreation

 

Description of issue: Video attached above of the issue. Counter launches and works fine only for the encounters where the text is hidden, whether it's by the window not being expanded fully or even if the hotbar covers up the text. While these may be examples that little players experience, it makes me not want to use the program because I like using PokeMMO split screen on my PC since I don't have enother monitor. My question is can this be fixed by grabbing data from battle chat instead of the current way? 

 

This is reproducable by clicking and dragging your hotbar over the battle text available in the game screen (not the battle chat). You can also have the window in a small enough size where the battle text cannot be seen.

 

Not much in the debug folder, just screenshots of me messing with the debug feature. No text in the .log files.

 

No error seen

 

I was using default theme

 

My UI scaling is 1.0x

Link to comment
1 hour ago, luiofficial said:

Bug report

 

Bug Recreation

 

Description of issue: Video attached above of the issue. Counter launches and works fine only for the encounters where the text is hidden, whether it's by the window not being expanded fully or even if the hotbar covers up the text. While these may be examples that little players experience, it makes me not want to use the program because I like using PokeMMO split screen on my PC since I don't have enother monitor. My question is can this be fixed by grabbing data from battle chat instead of the current way? 

 

This is reproducable by clicking and dragging your hotbar over the battle text available in the game screen (not the battle chat). You can also have the window in a small enough size where the battle text cannot be seen.

 

Not much in the debug folder, just screenshots of me messing with the debug feature. No text in the .log files.

 

No error seen

 

I was using default theme

 

My UI scaling is 1.0x

Hi luiofficial,

 

Yes this is known and will continue to operate this way in the future. There's no way around it. Normally the battle ui will appear on top of other ui elements, unless you are active in the other ui elements at the same time (i.e. you dragging the hotbar over the battle text). So you have to be pretty intentional about it...

 

For the app to function, it needs to be able to see the battle text in full. Dragging other PokeMMO ui elements over it, or making the battle ui too small will prevent the app from working.

Edited by Gilan
Link to comment
On 2/18/2022 at 5:33 AM, Gilan said:

if it's counting hordes but not other encounters. Then your ROM's translation doesn't match the translation for my GEC (assuming you have the correct language selected in the GEC settings). It could also potentially have something to do with your battle window's size (i.e. it's cutting out the "A wild {pokemon} appeared!" text in some fashion)

 

In v2.0 that I'm working on, the translation strings for the GEC will be in a separate file so that users can edit them as necessary. It seems 2 ROMs of the same language can have different translations apparently.

I'm not sure I see the point of this. That's what the pokedex is for, and you can keep track of EV gains through your pokemon's summary.

I reinstalled all my roms from another page, it still doesnt work. All i can do is wait for v2.0 i guess, thank you anyways

Link to comment
  • 2 weeks later...

Wondering if you could help.

 

Heres my error log from gecDebug

 

ERROR:root:gecException:
Traceback (most recent call last):
  File "GilansEncounterCounter.py", line 1294, in run_app
  File "GilansEncounterCounter.py", line 300, in refresh_font_info
  File "GilansEncounterCounter.py", line 133, in refresh_gui_info
  File "xml\etree\ElementTree.py", line 1196, in parse
  File "xml\etree\ElementTree.py", line 597, in parse
  File "<string>", line None
xml.etree.ElementTree.ParseError: not well-formed (invalid token): line 1, column 0
 

Thank you

Link to comment
  • 2 weeks later...
On 7/17/2021 at 12:22 PM, Gilan said:

ERROR:root:gecException:
Traceback (most recent call last):
  File "GilansEncounterCounter.py", line 1294, in run_app
  File "GilansEncounterCounter.py", line 300, in refresh_font_info
  File "GilansEncounterCounter.py", line 92, in refresh_gui_info
  File "GilansEncounterCounter.py", line 92, in <listcomp>
  File "codecs.py", line 321, in decode
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xb9 in position 2516: invalid start byte

What's the problem?

On 7/17/2021 at 12:22 PM, Gilan said:

 

 

Edited by Beth
Link to comment

Having an error after updating windows and graphics drivers last night

 

Traceback (most recent call last):
  File "gui.py", line 19, in <module>
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "PyInstaller\loader\pyimod03_importers.py", line 546, in exec_module
  File "pywinauto\__init__.py", line 89, in <module>
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "PyInstaller\loader\pyimod03_importers.py", line 546, in exec_module
  File "pywinauto\findwindows.py", line 42, in <module>
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "PyInstaller\loader\pyimod03_importers.py", line 546, in exec_module
  File "pywinauto\controls\__init__.py", line 36, in <module>
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "PyInstaller\loader\pyimod03_importers.py", line 546, in exec_module
  File "pywinauto\controls\uiawrapper.py", line 47, in <module>
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "PyInstaller\loader\pyimod03_importers.py", line 546, in exec_module
  File "pywinauto\uia_defines.py", line 181, in <module>
  File "pywinauto\uia_defines.py", line 169, in _build_pattern_ids_dic
  File "pywinauto\uia_defines.py", line 50, in __call__
  File "pywinauto\uia_defines.py", line 63, in __init__
AttributeError: module 'comtypes.gen.UIAutomationClient' has no attribute 'CUIAutomation'

 

tried a reinstall and no luck on fixing it.

any thoughts on this?

Link to comment

Thanks for making this. Been looking for one for awhile after just guessing how many encounters. Now I can know exactly. I will let you know of any bugs or anything. 

 

How do you make it auto-detect encounters? Or do I have to manually put the encounters in?

Edited by Tastroooo
Link to comment

Sadly to say it doesnt work for me. For some reason whenever I try to open the app it says "The app you are trying to install isn't a microsoft verified app". I have tried to fix this but I do not know how. Been researching this for over an hour and for some reason the app does not fix. If anyone has a way to fix this without the use of admin please pm me or reply to this. 

Link to comment
23 minutes ago, Tastroooo said:

Sadly to say it doesnt work for me. For some reason whenever I try to open the app it says "The app you are trying to install isn't a microsoft verified app". I have tried to fix this but I do not know how. Been researching this for over an hour and for some reason the app does not fix. If anyone has a way to fix this without the use of admin please pm me or reply to this. 

Due to the nature of the program if you cannot select "More info" and "Run anyway", then you most likely require elevated administrative privileges.

 

image.png

image.png

Link to comment
  • 2 weeks later...

I think I have a bug with my encounter counter, my counter counts my own Pokémon and not the pokémons I encounter. I play on a widescreen, on borderless windowed, maybe that. My screen resolution is 3440 x 1440 (game is 3440 x 1410). When I put the game in 1920 x 1080, the counter works though. Is there a fix for widescreen? Thank you.

Edit : It works sometimes, and doesn't work other times. I don't know what I do differently.

Edited by Gullzarr
Link to comment
  • 2 weeks later...

Does anybody happen to know how to get this encounter counter working on Mac?

 

After much tinkering I managed to find how to open PokeMMO client folder and extracted the download to the mods folder there, but when I try to launch the exe file I get an error.

 

Has anybody gotten this to work on Mac?

Link to comment

Hey i can't seem to get the encounter counter to work. I've tried a lot of different things and can't find any solution in the forum. 

Here is the debug notes, i hope you can help.

 

56367580039429844725236f2b30528e.png

Link to comment

Just curious if you could add a scroll bar to this mod? Doubt many will have the issue I am as you'd have to be using a broke mouse lol but I can't use your mod at all since I can't scroll down to start it.... if you know of a way I could get around this I'd really be glad to know. I've tried seeing if anyone else has had an issue with scrolling down in the settings but haven't found anything. Please note this isn't a bug or anything it's just I don't have a mouse with a functioning scroll wheel and I think that is the only way to scroll down in the settings to be able to start the counting.

Link to comment
7 hours ago, AmorphousEntity said:

Just curious if you could add a scroll bar to this mod? Doubt many will have the issue I am as you'd have to be using a broke mouse lol but I can't use your mod at all since I can't scroll down to start it.... if you know of a way I could get around this I'd really be glad to know. I've tried seeing if anyone else has had an issue with scrolling down in the settings but haven't found anything. Please note this isn't a bug or anything it's just I don't have a mouse with a functioning scroll wheel and I think that is the only way to scroll down in the settings to be able to start the counting.

You should be able to use the arrow keys, page up/ down and or the home and end keys in order to scroll. 

 

If you have a touchpad, you can turn on two finger scrolling.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use and Privacy Policy.